Module build failed: Error: Node Sass does not yet support your current environment: Windows 64-bit with Unsupported runtime (83)
当前环境:nodeJS版本14.15.4,node-saas版本4.12.0
造成原因:node版本过高,与node-SaaS版本不对应
解决方法:降低nodeJS版本,删除node-saas,重新运行 npm install
具体方法:
  1. 下载nvm(nodeJS版本管理软件)
  2. 运行cmd,输入nvm,显示如下图所示证明安装成功
  3. 查看当前安装的有哪些版本(nvm list)
  4. 查看有哪些可用版本(nvm ls available)
  5. 下载合适的版本(nvm install 版本号)
  6. 切换node版本(nvm use 12.18.1)
    1. 最后查看npm版本对应即切换成功

发表评论

电子邮件地址不会被公开。 必填项已用*标注