wordpress是目前最主流的博客搭建平台,站长们为了提高网站的安全都会在第一时间更新主题和插件,但是在升级新的WordPress版本或者是全新安装过后,可能会在浏览器里遇到这样的错误:Warning:Cannot modify header information – headers already sent by (output started at /path/blog/wp-config.php:34)

解决办法:删掉 wp-config.php 里面多余的空格,空行以及其他无用信息。

1. 通过 FTP 下载 wp-config.php 文件

2. 打开 wp-cinfig.php

3. 去除<?php 前面的所有空格。

4. 确保第一个字段是 <?php 并且 <?php 在第一行而且中间没有空格。

警告Warning:Cannot modify header information – headers already sent by

5.去除 ?> 后的所有空格。

6. 确保最后的字符是 ?>,放到最后一行,确保中间没有空格。

警告Warning:Cannot modify header information – headers already sent by

这个错误也可能会发生在其他的文件。我们需要仔细阅读错误信息,上面有记录出错的文件的位置,能帮我们准确的找到报错的地方。如果你在折腾wordpress的时候遇到了问题可以参考一下站点的其他文章。如果这篇文章帮到了你也希望你能多多关注本站点,我会每天定时更新不同分类下文章和教程。

发表评论

电子邮件地址不会被公开。 必填项已用*标注